P7: Unerklärliches Verhalten des Shaders

Moderator: Game Technology

firefluxx
Windoof-User
Windoof-User
Beiträge: 28
Registriert: 12. Feb 2014 14:55

P7: Unerklärliches Verhalten des Shaders

Beitrag von firefluxx » 14. Dez 2016 12:06

Hallo,

ich habe die einzelnen Teile für die Praxis 7 im Fragment Shader implementiert, dabei passieren irgendwie seltsame Dinge. Wenn ich für eine der Funktionen F, D und G ihren Rückgabewert auf das Berechnete setze und die anderen auf die standardmäßigen 1.0, funktioniert die jeweilige Funktion (mit der Mode-Wahl einzeln). F und D funktionieren auch zusammen. Aber sobald ich G normal nutze in Kombination mit F oder D, bleibt das Bild schwarz. Die Funktionen werden nur im IF über die Mode-Auswahl aufgerufen, sonst nirgendwo. Ich habe leider keine Ahnung was da passiert. :shock:

firefluxx
Windoof-User
Windoof-User
Beiträge: 28
Registriert: 12. Feb 2014 14:55

Re: P7: Unerklärliches Verhalten des Shaders

Beitrag von firefluxx » 14. Dez 2016 13:24

Oben beschriebenes Problem trat bei Win10 auf. Habe das ganze nochmals auf OS X getestet, dort funktioniert so wie es scheint alles normal. :?:

FloM-KOM
Moderator
Moderator
Beiträge: 279
Registriert: 27. Apr 2010 17:20

Re: P7: Unerklärliches Verhalten des Shaders

Beitrag von FloM-KOM » 14. Dez 2016 13:45

Das würde darauf hin deuten daß das Problem nur mit DirectX auftritt. Mit dem mode und DirectX gab es einen Fehler, s. https://www2.fachschaft.informatik.tu-d ... 57&t=35250, vielleicht hängt das auch zusammen. Sollte unter Windows mit Kore/make -g opengl2 auch funktionieren wenn es so ist.

Antworten

Zurück zu „Game Technology“