Seite 1 von 1

[SOLVED] SBT can't fetch the "sbt-submission" plugin

Verfasst: 24. Okt 2017 22:29
von CryNickSystems
Hey there,

I was just trying to work on the homework, but my SBT is not able to fetch the "sbt-submission" plugin.

As far as I can tell it is trying to fetch the URL "https://repo1.maven.org/maven2/de/tudar ... avadoc.jar", which returns a 404.

At least on the provided maven repo URL, there is no "stg" folder: https://repo1.maven.org/maven2/de/tudarmstadt/

So - is this an error on my end? Or did something go wrong when publishing the plugin (I doubt that).

Thanks.

By the way, I am using the latest IntelliJ on Windows 10 1709 and I am also suffering from this bug: https://github.com/sbt/sbt/issues/3560 Probably installing the latest SBT milestone is going to fix it, but why bother if compiling and executing the code works when using SBT to build and run.

Re: SBT can't fetch the "sbt-submission" plugin

Verfasst: 24. Okt 2017 23:54
von 0b101101101
Hello!

Actually, I believe sbt downloaded the plugin from "https://dl.bintray.com/stg-tud/sbt-plug ... t_1.0/1.0/".
Does your "project/plugins.sbt" file contain the line "resolvers += Resolver.bintrayIvyRepo("stg-tud", "sbt-plugins")" like mine does?
(http://www.scala-sbt.org/1.x/docs/Resolvers.html tells me this line should activate the dl.bintray.com repository).

Re: SBT can't fetch the "sbt-submission" plugin

Verfasst: 25. Okt 2017 00:12
von CryNickSystems
Yes, it does. It is the same as the template, I only made changes to the "Solution.scala" file...

Re: SBT can't fetch the "sbt-submission" plugin

Verfasst: 25. Okt 2017 09:59
von Ragnar
Hi, could you send the full log that sbt produces? The plugin is hosted on bintray, not maven central, so its not surprising that it is not found there :-).

For the other bug … that is very unfortunate. When you open the sbt project in IntelliJ, you can select to “Use SBT shell for build and ipmorts”, which tends to improve these kind of incompatibility problems.

Re: SBT can't fetch the "sbt-submission" plugin

Verfasst: 25. Okt 2017 18:43
von CryNickSystems
Okay, apparently re-importing the project (from scratch) fixed my problem... weird.

So I was finally able to submit my solution.