Latex: TU Corporate Design mit Umlauten ohne die \"-Krücke

Moderator: Aktive Fachschaft

muhaaa
Windoof-User
Windoof-User
Beiträge: 24
Registriert: 14. Jun 2008 16:37

Latex: TU Corporate Design mit Umlauten ohne die \"-Krücke

Beitrag von muhaaa »

Hallo,
ich schreibe meine Bachelor Thesis auf Deutsch und ich will nicht für jeden Umlaut (ä) sone Krücke (\"a) tippen müssen. mit suchen und ersetzten funktion im editor habe ich eine aussreichende lösung gefunden, aber wenn man dann im Nachhinein seinen Text überarbeitet, stört diese \"a den lesefluss sehr. Gibts ne möglichkeit dass ich in der latex datei direkt ä im text haben kann und sie später im pdf korrekt angezeigt werden, wenn ich das TU corporate design verwende.
Ich habe gegooglet und der 1 treffer lieferte mir folgende mgl:

Code: Alles auswählen

\usepackage[german]{babel}
\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc} 
die funktioniert aber nicht im corporate design.

Benutzeravatar
salted
Mausschubser
Mausschubser
Beiträge: 84
Registriert: 28. Sep 2009 21:21

Re: Latex: TU Corporate Design mit Umlauten ohne die \"-Krüc

Beitrag von salted »

muhaaa hat geschrieben:Hallo,

Code: Alles auswählen

\usepackage[german]{babel}
\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc} 
Ersetze "german" durch "ngerman". Das funktioniert bei mir zusammen mit dem Corporate Design.

muhaaa
Windoof-User
Windoof-User
Beiträge: 24
Registriert: 14. Jun 2008 16:37

Re: Latex: TU Corporate Design mit Umlauten ohne die \"-Krüc

Beitrag von muhaaa »

funktioniert bei mir leider nicht.

Sobald ich "\usepackage[latin1]{inputenc}" einbinde bekomme ich nen Fehler. In der Log stehen "0 errors, 2 warings and 3 badboxes", dennoch sagt PDFLaTeX "finished with exit code 1" und kein pdf wird generiert. Wenn ich "\usepackage[latin1]{inputenc}" auskommentiere, dann bekomme ich zwar immernoch die warnings und badboxes, aber PDFLaTeX kompliert das ohne probleme.

Fehlen eventuel irgendwelche Libraries oder Zusatzprogramme auf meinem Ubuntu? Kann das der Grund sein?

b_b
Erstie
Erstie
Beiträge: 15
Registriert: 7. Nov 2009 21:20

Re: Latex: TU Corporate Design mit Umlauten ohne die \"-Krüc

Beitrag von b_b »

Exitcode 1 signalisiert auch einen Fehler, 0 müsste er sein.

Im TU-Design funktioniert es mit diesen Packages (getestet mit der Beispieldatei TUD_doc.tex, TeX-Paket MacTeX Live 2009):

Code: Alles auswählen

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
Musst dann halt UTF-8 nehmen, aber das sollte ja wohl kein Problem darstellen.

muhaaa
Windoof-User
Windoof-User
Beiträge: 24
Registriert: 14. Jun 2008 16:37

Re: Latex: TU Corporate Design mit Umlauten ohne die \"-Krüc

Beitrag von muhaaa »

geil! jetzt klappt alles so wie ichs mir gewünscht habe. Danke! :-)

Wetterfrosch
Mausschubser
Mausschubser
Beiträge: 72
Registriert: 20. Jan 2007 15:51

Re: Latex: TU Corporate Design mit Umlauten ohne die \"-Krüc

Beitrag von Wetterfrosch »

Hallo,
mit dem Problem hatte ich auch zu kämpfen. Jetzt habe ich eine Lösung gefunden:
Mein System:
- Mac OS Lion
- TexShop
- Encoding: Western Mac Os Roman

Ich habe probiert das Encoding auf UTF8 oder Latin umzustellen. das hat aber nicht funktioniert. Jetzt habe ich im Cortporate Design folgende Änderungen vorgenommen:

Diese Paketes habe ich entfernt:
\usepackage{inputenc}
\usepackage{ngerman}
\usepackage[american,ngerman]{babel}
weiter unten habe ich noch
\selectlanguage{ngerman} % american ngerman entfernt

Dafür habe ich folgende Zeilen eingefügt:
\usepackage[applemac]{inputenc}
\usepackage[T1]{fontenc}

Umlaute mit dem Corperate Design funktionieren jetzt.

LucasR
Kernelcompilierer
Kernelcompilierer
Beiträge: 474
Registriert: 9. Jun 2009 09:55

Re: Latex: TU Corporate Design mit Umlauten ohne die \"-Krüc

Beitrag von LucasR »

Wetterfrosch hat geschrieben:Hallo,
mit dem Problem hatte ich auch zu kämpfen. Jetzt habe ich eine Lösung gefunden:
Mein System:
- Mac OS Lion
- TexShop
- Encoding: Western Mac Os Roman

Ich habe probiert das Encoding auf UTF8 oder Latin umzustellen. das hat aber nicht funktioniert. Jetzt habe ich im Cortporate Design folgende Änderungen vorgenommen:

Diese Paketes habe ich entfernt:
\usepackage{inputenc}
\usepackage{ngerman}
\usepackage[american,ngerman]{babel}
weiter unten habe ich noch
\selectlanguage{ngerman} % american ngerman entfernt

Dafür habe ich folgende Zeilen eingefügt:
\usepackage[applemac]{inputenc}
\usepackage[T1]{fontenc}

Umlaute mit dem Corperate Design funktionieren jetzt.
Aber nur, solange du die TeX-Files nicht einem nicht Mac-Nutzer gibst. Spätestens dann gibts wieder Probleme.

Benutzeravatar
olg
Sonntagsinformatiker
Sonntagsinformatiker
Beiträge: 297
Registriert: 1. Okt 2008 19:24

Re: Latex: TU Corporate Design mit Umlauten ohne die \"-Krüc

Beitrag von olg »

Bei mir funktioniert die Angabe

Code: Alles auswählen

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
auf Mac OSX Lion, pdflatex / latexmk einwandfrei. Du musst , wenn das nicht geht, wie Lucas gesagt hatte drauf aufpassen, wenn du mal was als .tex abgeben musst (Seminar z.b) , das dann zurückzuändern bzw. den Empfänger vorzuwarnen :)
Zuletzt geändert von olg am 12. Aug 2011 14:47, insgesamt 1-mal geändert.
"To Perl, or not to Perl, that is the kvetching." ~Larry Wall

Benutzeravatar
Michl
Sonntagsinformatiker
Sonntagsinformatiker
Beiträge: 293
Registriert: 12. Apr 2009 08:53
Wohnort: Darmstadt

Re: Latex: TU Corporate Design mit Umlauten ohne die \"-Krüc

Beitrag von Michl »

Oder man gew\"ohnt sich einfach daran Umlaute mit \" zu schreiben. ;)

Antworten

Zurück zu „Allgemein“