Adventskalender Problem

spyro.makedonski
BASIC-Programmierer
BASIC-Programmierer
Beiträge: 102
Registriert: 18. Apr 2010 13:45

Re: Adventskalender Problem

Beitrag von spyro.makedonski » 22. Dez 2010 19:46

22? das kann nicht sein... also -34 im byte ist 222 ... das ist was wir schicken (92, -63, 5, -34)

spyro.makedonski
BASIC-Programmierer
BASIC-Programmierer
Beiträge: 102
Registriert: 18. Apr 2010 13:45

Re: Adventskalender Problem

Beitrag von spyro.makedonski » 22. Dez 2010 19:49

also vielleicht hast du gesehen dass ich einmal 22 gegeben habe weil ich wollte probieren was passiert wenn ich falsche IP gebe... dann bekomme ich exception (unknown source oder sowas)

Benutzeravatar
BadTaste
Endlosschleifenbastler
Endlosschleifenbastler
Beiträge: 181
Registriert: 18. Apr 2005 16:40
Wohnort: Darmstadt
Kontaktdaten:

Re: Adventskalender Problem

Beitrag von BadTaste » 22. Dez 2010 19:53

den logs kann ich entnehmen, dass ihr häufig (gerade wohl wieder) des FD angefragt habt.
zwei mal habt ihr wohl mit falscher IP im header (*.22) angefragt.

spyro.makedonski
BASIC-Programmierer
BASIC-Programmierer
Beiträge: 102
Registriert: 18. Apr 2010 13:45

Re: Adventskalender Problem

Beitrag von spyro.makedonski » 22. Dez 2010 20:02

also wenn der Server die FD schickt und wir -1 von read() bekommen dann ist das Problem bei mir mit dem LAN....

Thorsten Peter
Windoof-User
Windoof-User
Beiträge: 27
Registriert: 18. Mai 2009 23:40

Re: Adventskalender Problem

Beitrag von Thorsten Peter » 23. Dez 2010 13:08

Hiho,

hat für das aktuelle MP3-File noch jmd. außer mir Chunks erhalten, die zum größten Teil mit Nullen besetzt sind (siehe HexEditor) oder klappt's bei jmd. ganz normal?

Viele Grüße
Thorsten

EDIT: Für diejenigen, die das gleiche problem haben sollten....Schaut mal da hin wo ihr vom Stream lest und schaut genau wieviel bytes und wann diese bytes da gelesen werden. (Glaube zumindest das wars bei uns)

Christoph B
Computerversteher
Computerversteher
Beiträge: 370
Registriert: 15. Okt 2006 18:28
Wohnort: Wiesbaden
Kontaktdaten:

Re: Adventskalender Problem

Beitrag von Christoph B » 23. Dez 2010 14:52

hm, aktuell krieg ich garkeine Antwort mehr auf meinen Request nach dem FileDescriptor. Aber heut morgen hat ich wohl das gleiche Problem, da kam eine ganz komische Antwort auf meinen ersten Chunk Requests (fast so als würde auf Server Seite die Datei fehlen).

Thorsten Peter
Windoof-User
Windoof-User
Beiträge: 27
Registriert: 18. Mai 2009 23:40

Re: Adventskalender Problem

Beitrag von Thorsten Peter » 23. Dez 2010 15:17

Der Server antwortet auch bei uns nicht. Habe gerade eine Stunde auf den FileDescriptor gewartet, aber der kam nicht.

Christoph B
Computerversteher
Computerversteher
Beiträge: 370
Registriert: 15. Okt 2006 18:28
Wohnort: Wiesbaden
Kontaktdaten:

Re: Adventskalender Problem

Beitrag von Christoph B » 23. Dez 2010 16:56

aaah, jetz wo´s wieder klappt mit dem FileDescriptor konnt ichs debuggen:
Anscheinend liefert der Server die Daten nicht schnell genug, oder Java´s InputStream kann die Chunkgröße nicht handeln.
Statt wie bisher einfach die komplette payload in einem Rutsch aus dem Buffer zu lesen => einfach mehrere Calls bis alle bytes empfangen wurden und der Download läuft nun (wenn auch sehr sehr langsam).
Heißt dann nur noch Daumen drücken, dass der Download durchläuft bevor der Server wieder abkackt :(

Thorsten Peter
Windoof-User
Windoof-User
Beiträge: 27
Registriert: 18. Mai 2009 23:40

Re: Adventskalender Problem

Beitrag von Thorsten Peter » 23. Dez 2010 16:59

Japp, das hatte ich gemeint. Allerdings bekomme ich den Descriptor immer noch nicht!??!

Christoph B
Computerversteher
Computerversteher
Beiträge: 370
Registriert: 15. Okt 2006 18:28
Wohnort: Wiesbaden
Kontaktdaten:

Re: Adventskalender Problem

Beitrag von Christoph B » 23. Dez 2010 17:09

Jo, konnt auch nur 1.53 MB Downloaden bevor der Server wieder down war, aber das reicht zum Glück für ne Beschreibung.

Thorsten Peter
Windoof-User
Windoof-User
Beiträge: 27
Registriert: 18. Mai 2009 23:40

Re: Adventskalender Problem

Beitrag von Thorsten Peter » 23. Dez 2010 17:32

Juhu, hab 1,4 mb bekommen, das reicht dann wohl auch :-)

z.z.
Mausschubser
Mausschubser
Beiträge: 50
Registriert: 2. Apr 2008 11:44
Kontaktdaten:

Re: Adventskalender Problem

Beitrag von z.z. » 23. Dez 2010 17:38

der server kackt nicht ab, es sind Implementierungen, die fehlerhaft implementiert sind oder teams, die nachwievor ihre portforwardings nicht umgesetzt bekommen, die den server blockieren.

Es gibt viele Gruppen, die auch das heutige file vollständig heruntergeladen haben. Für alle die es bisher noch nicht geschafft haben das file herunterzuladen:

1) Firewall/Router/Portforwarding checken

2) den einkommenden stream in kleinen stücken einlesen, bis ein vollständiger chunk empfangen wurde

3) diesen chunk persistent wegschreiben und nicht im ram behalten.

Thorsten Peter
Windoof-User
Windoof-User
Beiträge: 27
Registriert: 18. Mai 2009 23:40

Re: Adventskalender Problem

Beitrag von Thorsten Peter » 23. Dez 2010 17:44

Jetzt im Moment geht's, konnte das ganze file laden

Benutzeravatar
olg
Sonntagsinformatiker
Sonntagsinformatiker
Beiträge: 297
Registriert: 1. Okt 2008 19:24

Re: Adventskalender Problem

Beitrag von olg » 23. Dez 2010 17:55

Ich kann die Datei wiederholt (fast) vollständig runterladen, nur mit genau einem einzelnen Chunk (auch immer das gleiche) haben wir - auch unter verschiedenen Verbindungen -Probleme - es kommt einfach keine Antwort für diese eine ID "filename:27". Kann das jemand bestätigungen oder hat eine Ahnung, woran sowas liegen könnte? Wie gesagt, alle anderen Chunks werden einwandfrei geschickt/erkannt.
"To Perl, or not to Perl, that is the kvetching." ~Larry Wall

Antworten

Zurück zu „Archiv“