Installation der Scala-IDE

fetzer
Kernelcompilierer
Kernelcompilierer
Beiträge: 522
Registriert: 1. Okt 2008 17:18

Installation der Scala-IDE

Beitrag von fetzer » 20. Apr 2011 16:10

Hi,

bei mir funktioniert die Scala-IDE nicht korrekt. Die Installation verläuft korrekt, der darauf folgende Neustart funktioniert ebenfalls. Server, wie auch Client lassen sich problemlos starten.
Nach einem weiteren Start von Eclipse funktioniert jedoch nichts mehr. Beim Starten von Eclipse erhalte ich folgende Meldungen:
The org.eclipse.jdt.ui.javaElementFilters plug-in extension "scala.tools.eclipse.javaelements.ScalaElementFilter" specifies a viewer filter class which does not exist.
Plug-in org.scala-ide.sdt.core was unable to load class scala.tools.eclipse.javaelements.ScalaElementFilter.
An error occurred while automatically activating bundle org.scala-ide.sdt.core (212).
und
Errors occurred during the build.
Error instantiating builder 'org.scala-ide.sdt.core.scalabuilder'.
Plug-in org.scala-ide.sdt.core was unable to load class scala.tools.eclipse.ScalaBuilder.
An error occurred while automatically activating bundle org.scala-ide.sdt.core (212).
Plug-in org.scala-ide.sdt.core was unable to load class scala.tools.eclipse.ScalaBuilder.
An error occurred while automatically activating bundle org.scala-ide.sdt.core (212).
Im Error-Log werden mir noch nen Haufen weiterer Fehler angezeigt. Wenns helfen sollte kann ich sie natürlich nachliefern. Es geht dabei hauptsächlich um Fehler der Form "Plug-in org.scala-ide.sdt.core was unable to load class [...]".

Ausgangslage ist ein frisch installiertes Eclipse Classic (manuell über die Eclipse-Website) unter Ubuntu 10.10. Scala-IDE liegt in Version "2.0.0-beta2 with Scala 2.9.0.RC1" vor, Scala begrüßt mich mit "Welcome to Scala version 2.9.0.RC1 (Java HotSpot(TM) Server VM, Java 1.6.0_24).".

Ne Lösung jemand? ;)

edit:
So nach 2h Fehlersuche Try'n'Error habe ich etwas gefunden: Wenn eine Scala/Java-Datei oder keine Datei beim Start von Eclipse geöffnet ist funktioniert die Scala-IDE und wird korrekt geladen. Ist aber z.B. eine Properties-Datei geöffnet, so funktioniert die IDE nicht mehr. Merkwürdiger Fehler, aber immerhin ein kleiner Workaround..

eichberg
Dozentin/Dozent
Beiträge: 448
Registriert: 25. Sep 2007 12:12
Kontaktdaten:

Re: Installation der Scala-IDE

Beitrag von eichberg » 20. Apr 2011 22:06

Es entspricht auch meiner Erfahrung, dass es im Falle von Problemen am Besten ist, die IDE neu zu starten und vorher alle Fenster zu schließen. Allerdings hatte ich - nach dem ich diese einmalig getan hatte - danach keine weiteren Probleme mehr.

(Sowohl und Unter Ubuntu als auch Mac OS X).

Antworten

Zurück zu „Archiv“