Seite 1 von 1

Übung 6 - Firefox-plugin

Verfasst: 7. Jul 2011 14:58
von Vladimir
Hallo,

ich kann das plugin nicht installieren(

zuerst kamm der folgende Fehler von Firefox 5.0: "this add-on could not be installed because it appears to be corrupt."
und von Firefox 3.6.17: "The to install file can not be found"

hat jemand das selbe?

Re: Übung 6 - Firefox-plugin

Verfasst: 7. Jul 2011 15:17
von olg
Unter Verwendung des Addon-SDK und dem darin enthaltenen Tool cfx kann man das Plugin wieder zu einem 'korrektem' Addon bauen. Nach der Installation dieser erstellten xpi lassen sich die Dateien dann im nachhinein manipulieren, ohne das Firefox rummault.

Falls das jemand unter Mac ausprobiert: im contextSelect.js die Abfrage auf event.altKey ändern, da strg+klick ein systemhook hat und daher vorher abgefangen wird - und damit auch keine Ausgabe produziert. (Auswahl dann logischerweise mit alt + klick)