HU-Aufgabe-2 : Ergebnise vergleichen

levitin
Kernelcompilierer
Kernelcompilierer
Beiträge: 435
Registriert: 7. Okt 2007 15:36
Wohnort: Darmstadt

HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von levitin »

Ich habe so was bekommen. Hat jemand das gleiche?

CBC(SYSTEM) = ?RYCXC
CFB(CHIFFRAT) = MQVA!_GT
OFB(PROTOCOL) = !!I-EHZ.

honky-tonk
Erstie
Erstie
Beiträge: 13
Registriert: 13. Okt 2009 16:58

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von honky-tonk »

erste hab ich genauso, bei dem dritten habe ich ein ? ganz hinten und das zweite ist komplett verschieden...die 2te is auch bös...wenn man sich einmal vertut zieht sich der fehler durch :x

Benutzeravatar
Demmi
Kernelcompilierer
Kernelcompilierer
Beiträge: 423
Registriert: 1. Okt 2007 12:56
Wohnort: Darmstadt

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von Demmi »

levitin hat geschrieben:Ich habe so was bekommen. Hat jemand das gleiche?

CBC(SYSTEM) = ?RYCXC
CFB(CHIFFRAT) = MQVA!_GT
OFB(PROTOCOL) = !!I-EHZ.
Kann ich bestätigen
Saying that Java is nice because it works on all Plattforms is like saying that anal sex is nice because it works on all genders.

honky-tonk
Erstie
Erstie
Beiträge: 13
Registriert: 13. Okt 2009 16:58

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von honky-tonk »

ok meinen fehler im OFB habe ich gefunden hab einfach einmal am ende falsch verexort.. :roll:

aber bei der zweiten Aufgabe finde ich meinen Fehler nicht...mein erster Chiffratblock ist 0110=6...soweit müsste meine Lösung noch stimmen... dann nehme ich diese Zahl in E(m) und bekomme 56...nach dem umwandeln in binär verwende ich die linken 4bits und verexore dies mit dem 2ten Block des Klartexts und bekomme 0100 was aber laut eurer Lösung 1100 sein müsste :?:

...ist in meinem generellen Vorgehen ein Fehler?

gruß und danke

levitin
Kernelcompilierer
Kernelcompilierer
Beiträge: 435
Registriert: 7. Okt 2007 15:36
Wohnort: Darmstadt

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von levitin »

honky-tonk hat geschrieben:dann nehme ich diese Zahl in E(m) und bekomme 56...
Ij+1 ensteht, indem in Ij die ersten r Bits gelöscht werden und cj hinten angehängt wird.
erst dann kannst du Oj berechnen, indem du die Funtktion E auf Ij anwendest

honky-tonk
Erstie
Erstie
Beiträge: 13
Registriert: 13. Okt 2009 16:58

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von honky-tonk »

ok...DAKE...verstanden...hab mich schon gefragt was der bitshift bedeutet :wink:

Benutzeravatar
crib
Mausschubser
Mausschubser
Beiträge: 46
Registriert: 17. Apr 2008 14:43
Wohnort: Wiesbaden

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von crib »

Demmi hat geschrieben:
levitin hat geschrieben:Ich habe so was bekommen. Hat jemand das gleiche?

CBC(SYSTEM) = ?RYCXC
CFB(CHIFFRAT) = MQVA!_GT
OFB(PROTOCOL) = !!I-EHZ.
Kann ich bestätigen
Stimmt mit meiner Lösung ebenfalls überein.

Benutzeravatar
Blub
Sonntagsinformatiker
Sonntagsinformatiker
Beiträge: 244
Registriert: 24. Dez 2007 14:06

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von Blub »

ich habe schon wieder was anderes raus .____. Ich bin scheinbar wirklich zu unfähig zum rechnen ^^ naja, alle guten Dinge sind ja 3 :p
Tutor GDI II SS12
Tutor Trusted Systems WS11/12, Tutor GDI II SS11
Tutor Trusted Systems WS10/11, GDI I WS10/11
Tutor GDI II SS10, Tutor Trusted Systems WS09/10

ohoffman
Erstie
Erstie
Beiträge: 22
Registriert: 21. Apr 2009 01:06

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von ohoffman »

Sicher, dass es beim CFB ein T am Ende ist? Habe dort ein R stehen, aber der Rest ist identisch!!!

ohoffman
Erstie
Erstie
Beiträge: 22
Registriert: 21. Apr 2009 01:06

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von ohoffman »

ohoffman hat geschrieben:Sicher, dass es beim CFB ein T am Ende ist? Habe dort ein R stehen, aber der Rest ist identisch!!!
fehler gefunden... ist doch ein T :)

niewhner
Nichts ist wie es scheint
Beiträge: 23
Registriert: 17. Jun 2009 13:42

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von niewhner »

Ich habe jetzt schon zum 2. mal eine falsche Lösung bei dem CFB Mode. Vielleicht kann mir einer sagen ob ich die richtigen Schritte durchführe oder ich vollkommen falsch liege.

Mein I1 entspricht dem IV = 101010, darauf wende ich E an und bekomme mein O, davon nehme ich die ersten 4 bits und verXOR mit meinem m1 ( m1 = 0001) und bekomme dann mein C1. Mein I2 bekomme ich dann indem ich die letzten 2 bits von I1 nehme und daran mein C1 hänge. Das mache ich bis ich alle m-Blöcke durch habe.

tigris
Mausschubser
Mausschubser
Beiträge: 89
Registriert: 2. Okt 2008 13:49

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von tigris »

niewhner hat geschrieben: Mein I1 entspricht dem IV = 101010, darauf wende ich E an und bekomme mein O, davon nehme ich die ersten 4 bits und verXOR mit meinem m1 ( m1 = 0001) und bekomme dann mein C1. Mein I2 bekomme ich dann indem ich die letzten 2 bits von I1 nehme und daran mein C1 hänge. Das mache ich bis ich alle m-Blöcke durch habe.
Sehe ich genauso. Nur ich komme damit auf die gleiche Lösung wie alle anderen hier.
Zur Sicherheit mal folgende:
I1=101010 O1=011100 C1=0110 m1=0001
I2=100110 O2=011000 C2=1100 m2=1010
I3=101100 ....

niewhner
Nichts ist wie es scheint
Beiträge: 23
Registriert: 17. Jun 2009 13:42

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von niewhner »

tigris hat geschrieben:
Sehe ich genauso. Nur ich komme damit auf die gleiche Lösung wie alle anderen hier.
Zur Sicherheit mal folgende:
I1=101010 O1=011100 C1=0110 m1=0001
I2=100110 O2=011000 C2=1100 m2=1010
I3=101100 ....

Ok wie es aussieht ist mein O falsch. Und ich weiß auch woran es liegt, mein erstes O war 11100, ich hab ganz einfach eine 0 vergessen und dadurch ist alles andere falsch.

tigris
Mausschubser
Mausschubser
Beiträge: 89
Registriert: 2. Okt 2008 13:49

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von tigris »

niewhner hat geschrieben:ich hab ganz einfach eine 0 vergessen und dadurch ist alles andere falsch.
*G* du oder der Windows Rechner (der ja keine führenden Nullen anzeigt)? Ich hatte das gleiche Problem auch vor längerer Zeit, hatte das aber schon wieder ganz vergessen.

niewhner
Nichts ist wie es scheint
Beiträge: 23
Registriert: 17. Jun 2009 13:42

Re: HU-Aufgabe-2 : Ergebnise vergleichen

Beitrag von niewhner »

tigris hat geschrieben: *G* du oder der Windows Rechner (der ja keine führenden Nullen anzeigt)? Ich hatte das gleiche Problem auch vor längerer Zeit, hatte das aber schon wieder ganz vergessen.

Diesmal war ich daran Schuld, ausnahmsweiße mal.

Antworten

Zurück zu „Archiv“