Quiz Projekt - Welche JRE?

Sascha-Thorsten
Mausschubser
Mausschubser
Beiträge: 51
Registriert: 4. Okt 2010 09:20

Quiz Projekt - Welche JRE?

Beitrag von Sascha-Thorsten »

Hallo,

ich wollte gerade am Quiz arbeiten und habe FindBugs ausgeführt. Als ich dann in der Java Dokumentation nach JList.getSelectedValues gesucht habe, fand ich keine Aussage darüber, ob diese Methode deprecated ist. Welche JRE sollen wir denn nutzen? Java 6 oder Java 7?

Viele Grüße
Sascha

Benutzeravatar
Domac
Endlosschleifenbastler
Endlosschleifenbastler
Beiträge: 160
Registriert: 4. Okt 2010 16:11

Re: Quiz Projekt - Welche JRE?

Beitrag von Domac »

Ich meine JRE 7. Ich arbeite damit und habe keine Probleme.
Ich frage mich hier jedoch, ob man bei dieser Aufgabe ein neues Interface für Fragen implementieren soll?
Dann würde die Kontrolle der Aufgaben etwas aus dem Ruder laufen… daher denke ich nicht, dass es der Fall sein wird?
Bin ich da richtig in meiner Annahme?

Gruß
Extend my dropbox space (here).
Thanks!

noelma
Mausschubser
Mausschubser
Beiträge: 54
Registriert: 15. Apr 2010 12:40

Re: Quiz Projekt - Welche JRE?

Beitrag von noelma »

Sascha-Thorsten hat geschrieben:Hallo,

Als ich dann in der Java Dokumentation nach JList.getSelectedValues gesucht habe, fand ich keine Aussage darüber, ob diese Methode deprecated ist.
In Java 7 ist die Methode deprecated.
Nachschauen kann man das auch hier für Java 7 und hier für Java 6
Domac hat geschrieben: Ich frage mich hier jedoch, ob man bei dieser Aufgabe ein neues Interface für Fragen implementieren soll?
Dann würde die Kontrolle der Aufgaben etwas aus dem Ruder laufen… daher denke ich nicht, dass es der Fall sein wird?
Bin ich da richtig in meiner Annahme?
Ihr sollt so wenig wie möglich an dem bestehenden Quellcode ändern und das Mittel der Vererbung nutzen. Somit sehe ich jetzt nicht die Notwendigkeit ein neues Interface zu implementieren, sondern nur neue Klassen.
EiSE Tutorin WS 12/13

Sascha-Thorsten
Mausschubser
Mausschubser
Beiträge: 51
Registriert: 4. Okt 2010 09:20

Re: Quiz Projekt - Welche JRE?

Beitrag von Sascha-Thorsten »

Heißt das nun, dass wir Java 7 nutzen sollten?

Hentschel
Mausschubser
Mausschubser
Beiträge: 62
Registriert: 1. Okt 2012 16:15

Re: Quiz Projekt - Welche JRE?

Beitrag von Hentschel »

Hallo,

die Anwendung habe ich mit Java 6 implementiert. Dort sollte es keine Warnungen geben.
Natürlich funktioniert sie auch mit Java 7. Warnungen können dann ignoriert werden und müssen nicht von Ihnen behoben werden.

Mfg

Martin

Antworten

Zurück zu „Archiv“