Pfad nicht gefunden...

Benutzeravatar
ut53xuco
Mausschubser
Mausschubser
Beiträge: 57
Registriert: 20. Nov 2011 18:07

Pfad nicht gefunden...

Beitrag von ut53xuco » 19. Jan 2012 16:22

Hi,

Ich möchte auf dem Gris-Rechner das Pr5 mal zum laufen bringen. Ich führe in ~/p5/nvidia "cmake ." aus, "make" und dann bei "./Praktikum5" kommt folgendes:

Code: Alles auswählen

Error: no input file has been provided
parameter syntax is:
-i=<infile>
[-cpu for CPU computation (default: GPU)]
[-oclgpu use GPU to compute via OpenCL, is ignored if -cpu is on (default: OCLCPU)]


Ich habe bereits in der pr5.cpp versucht das "-i=" durch "-i=<~/p5/test.fasta>" oder "-i=~/p5/test.fasta" zu ersetzten.
Dann kommt aber nur:

Code: Alles auswählen

-i=~/p5/test.fasta<infile>
Wer kann mir helfen?

SupeRalF
Mausschubser
Mausschubser
Beiträge: 56
Registriert: 4. Okt 2010 16:48

Re: Pfad nicht gefunden...

Beitrag von SupeRalF » 19. Jan 2012 16:43

Ich habe mir die Datei einfach in meinen build ordner kopiert, also direkt neben die executable. dann musst du nur noch mit dem parameter -i=test.fasta starten, ohne einen pfad anzugeben.

mw1039
Computerversteher
Computerversteher
Beiträge: 346
Registriert: 12. Apr 2011 12:18

Re: Pfad nicht gefunden...

Beitrag von mw1039 » 19. Jan 2012 18:44

ut53xuco hat geschrieben:Ich habe bereits in der pr5.cpp versucht das "-i=" durch "-i=<~/p5/test.fasta>" oder "-i=~/p5/test.fasta" zu ersetzten.
< und > brauchst du nicht und die Tilde loest das Programm nicht von alleine auf. Du musst den kompletten Pfad oder einen relativen Pfad (z.B. -i=../test.fasta) angeben.

Antworten

Zurück zu „Archiv“