WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10.10

Moderator: Aktive Fachschaft

ome
Erstie
Erstie
Beiträge: 11
Registriert: 30. Okt 2009 15:24
Wohnort: Darmstadt, Martinsviertel
Kontaktdaten:

WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10.10

Beitrag von ome » 3. Nov 2010 09:30

Hallo!

Ich bin neuer stolzer Besitzer eines Samsung N220 Plus und habe - wie es sich für einen anständigen Informatiker gehört - als erstes eine Linux-Distribution installiert. Meine Wahl fiel auf Ubuntu 10.10.

Ich bin noch nicht ganz fertig mit dem Kleinen, aber was mich am meisten stört sind die Verbindungsabbrüche mit eduroam. Wenn ich das Gerät einschalte, anmelde komme ich immer ins WLAN. Nach einigen Minuten, weniger als 20 auf jeden Fall, bricht die Verbindung ab und eine neue Verbindung lässt sich nicht herstellen. Sehr ärgerlich! Vor allem beobachte ich das Verhalten im Hexagon (habe dort meine Vorlesungen), aber auch wo anders. Zuhause und bei anderen, "normalen" WPA/WPA2-geschützen Funknetzwerken komme ich ohne Probleme und die Verbindung wird gehalten.

Ich vermute daher, dass irgendwelche Parameter nicht stimmen, generell funktioniert ja das WLAN-Modul. Kann mir jemand helfen? In welchen Logs sollte ich mal schauen? Welche Parameter sind wichtig, die ich nicht über den Gnome Network Manager einstellen kann? Oder sind da auch welche, die ich vergessen habe? Generell MÜSSEN die Zugangsdaten ja stimmen, sonst würde ich ja nie ins Netzwerk kommen.

Vielen Dank für die freundlichen Beiträge!

Benutzeravatar
Michl
Sonntagsinformatiker
Sonntagsinformatiker
Beiträge: 293
Registriert: 12. Apr 2009 08:53
Wohnort: Darmstadt

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von Michl » 3. Nov 2010 10:49

Das scheint derzeit ein generelles Problem mit eduroam zu sein, ich glaube sogar es liegt irgendwo an der Konfiguration des DHCP Servers- ich bekomme nämlich nur manchmal eine IP zugewiesen (ein oder zweimal die Woche).

orioon
Mausschubser
Mausschubser
Beiträge: 63
Registriert: 7. Okt 2009 13:07
Wohnort: Frankfurt

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von orioon » 3. Nov 2010 14:19

ich weiß ja nicht wie das bei Linux war, aber bei Windows läuft das WLAN im stromsparmodus standardmäßig, sofern man nicht das "High Performance" Energieprofil wählt.
Hatte bis jetzt unter Win7 keine Probs, meine Ubuntu VM ebenfalls nicht. (bis auf nen größeren Ausfall gestern, aber die liefen selbst die Poolrechner nicht reibungslos...)

Benutzeravatar
tiwoc
Ehemalige Fachschaftler
Beiträge: 475
Registriert: 21. Okt 2005 14:25
Kontaktdaten:

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von tiwoc » 11. Nov 2010 12:26

Ich habe mir das Problem angeschaut, weil ich es auch habe (Rechner läuft unter Ubuntu 10.10, 64 bit). Die Clients müssen sich regelmäßig reauthentifizieren, um im Netz zu bleiben. Dabei gibt es häufig Timeouts.

Ich stehe momentan im Kontakt mit dem HRZ zu diesem Thema: Es gibt ein Problem mit sehr langsamen Antworten des LDAP-Servers, der die Benutzerdaten verwaltet. Sie kümmern sich darum...

Ein zweites Problem ist im Laufe des Mailwechsels aufgefallen: In der offiziellen Anleitung des HRZ wird (indirekt) angegeben, dass man das Telekom-Root-Zertifikat im (einzigen angebotenen) DER-Format angeben soll. Das führt aber zu einer OpenSSL-Fehlermeldung im Syslog. Die Verbindung wird trotzdem aufgebaut, aber vermutlich ohne Zertifikatsprüfung. Es funktioniert allerdings, wenn man das Zertifikat im PEM-Format angibt:

Konvertierung mit OpenSSL:

Code: Alles auswählen

openssl x509 -inform DER -in telekom-root.der -outform PEM -out telekom-root.pem
Die entstandene .pem-Datei gibt man dann im entsprechenden Dialog im Network Manager an. Die offizielle Anleitung wird wohl bald korrigiert.

Nachtrag:
Dass die Verbindung trotz fehlgeschlagener Zertifikatsprüfung nicht abgebrochen wird, ist natürlich ein Sicherheitsproblem. Ich habe einen Bug-Report geschrieben; bin mal gespannt, wie es damit weiter geht.

azrael
Erstie
Erstie
Beiträge: 22
Registriert: 8. Apr 2011 19:33

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von azrael » 27. Apr 2011 19:26

Hallo,

das Problem existiert für mich auch, wie ist der Stand der Dinge?

Außerdem passiert mir das gleiche auch mit dem VPN-Zugang über die Netzwerkdosen (im Pool): Anfangs hab ich Internet, nach ein paar Minuten muss ich vpnc neustarten. Wenigstens funktioniert das, im Gegensatz zum wiederverbinden mit eduroam. Ich nutze Ubuntu 10.10, den NetworkManager und vpnc 0.5.3 aus dem universe-Repository.

--azrael

Benutzeravatar
tiwoc
Ehemalige Fachschaftler
Beiträge: 475
Registriert: 21. Okt 2005 14:25
Kontaktdaten:

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von tiwoc » 27. Apr 2011 21:01

Nichts Neues :-/

mister_tt
Kernelcompilierer
Kernelcompilierer
Beiträge: 502
Registriert: 29. Sep 2008 15:54

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von mister_tt » 28. Apr 2011 18:15

Ich habe dasselbe Problem und es nervt mich extrem. War heute dann einfach mal bei der HRZ Beratung und da wurde das Ganze genau aufgeschrieben. Rückmeldung soll es heute oder morgen schon geben. Ich poste hier dann (hoffentlich) die Fortschritte :-)

Benutzeravatar
AlexPi11
Endlosschleifenbastler
Endlosschleifenbastler
Beiträge: 154
Registriert: 18. Apr 2009 15:32

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von AlexPi11 » 28. Apr 2011 18:30

azrael hat geschrieben:[...]
Wenigstens funktioniert das, im Gegensatz zum wiederverbinden mit eduroam. [...]
Also das Wiederverbinden ist bei mir kein Problem. Das Erhalten einer IP ist da irgendwie Problematischer. Aber wenn man mit dhclient wlanXYZ nachhilft gehts (meistens, für eine gewisse Zeit... :roll: ). Probleme mit dem wlan hatte ich nun schon öfters die letzten Semester - manchmal läufts ganz gut, manchmal eher schlecht als recht.

Naja mal schauen was bei rum kommt.

mister_tt
Kernelcompilierer
Kernelcompilierer
Beiträge: 502
Registriert: 29. Sep 2008 15:54

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von mister_tt » 30. Apr 2011 15:42

Folgende Antwort habe ich vorhin erhalten:
ja, das ist ein (nervtötender) Bug im Network-Manager unter Ubuntu (bei
ArchLinux tritt der Fehler nicht so massiv auf). Einzige Lösung ist
sudo restart network-manager .

Danach geht es wieder für ein paar Minuten. Repeat as required... ;)

Ich hoffe, dass das Problem mit 11.04 behoben ist, aber ich hatte noch
keine Zeit mir eine Vorabversion von Natty anzusehen.
Habe jetzt schon auf Natty upgegradet, mal schauen, wie es am Montag in der Uni ist :-)

Benutzeravatar
salted
Mausschubser
Mausschubser
Beiträge: 84
Registriert: 28. Sep 2009 21:21

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von salted » 30. Apr 2011 15:46

mister_tt hat geschrieben:Folgende Antwort habe ich vorhin erhalten:
ja, das ist ein (nervtötender) Bug im Network-Manager unter Ubuntu (bei
ArchLinux tritt der Fehler nicht so massiv auf). Einzige Lösung ist
sudo restart network-manager .

Danach geht es wieder für ein paar Minuten. Repeat as required... ;)

Ich hoffe, dass das Problem mit 11.04 behoben ist, aber ich hatte noch
keine Zeit mir eine Vorabversion von Natty anzusehen.
Habe jetzt schon auf Natty upgegradet, mal schauen, wie es am Montag in der Uni ist :-)
Subjektiv ist es am Freitag mit Natty eher schlimmer geworden... :(

fetzer
Kernelcompilierer
Kernelcompilierer
Beiträge: 522
Registriert: 1. Okt 2008 17:18

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von fetzer » 30. Apr 2011 17:05

Offtopic:
salted hat geschrieben:Subjektiv ist es am Freitag mit Natty eher schlimmer geworden... :(
Subjektiv ist alles schlechter geworden mit Natty..


Benutzeravatar
tiwoc
Ehemalige Fachschaftler
Beiträge: 475
Registriert: 21. Okt 2005 14:25
Kontaktdaten:

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von tiwoc » 11. Jul 2011 01:47

Ich habe das Problem bei mir jetzt beheben können, indem ich dem Vorschlag aus der Diskussion zum Bugreport gefolgt bin, wpasupplicant mit GnuTLS statt mit OpenSSL zu kompilieren. Jetzt kann ich endlich wieder in der Uni stressfrei online sein :)

Fehlt nur noch, dass jemand herausfindet, was mit OpenSSL eigentlich das Problem ist. Wenn man das Problem auf Kommando reproduzieren könnte...

FelixG
Erstie
Erstie
Beiträge: 19
Registriert: 28. Sep 2009 16:12

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von FelixG » 13. Jul 2011 13:04

Jep. Danke für den Hinweis.
Mit GnuTLS funktioniert es! :)

Benutzeravatar
Demmi
Kernelcompilierer
Kernelcompilierer
Beiträge: 423
Registriert: 1. Okt 2007 12:56
Wohnort: Darmstadt

Re: WLAN eduroam - Verbindungsabbrüche Netbook mit Ubuntu 10

Beitrag von Demmi » 15. Jul 2011 12:13

Wie schauts eigtl. mit Android aus? Ich fliege auch laufend aus dem Eduroam mit meinem Defy mit 2.2.2 drauf. Da kann ich schlecht was am WLAN-Stack rumbasteln.
Aber das Problem scheint auch für andere Modelle zu bestehen, weil ich kenne genügend Leute mit Android-Smartphones verschiedener Generationen, die am Fluchen sind.
Irgendjemand ne Idee?
Saying that Java is nice because it works on all Plattforms is like saying that anal sex is nice because it works on all genders.

Antworten

Zurück zu „Offtopic“