Die Suche ergab 7 Treffer

von Lucas-
4. Feb 2012 13:47
Forum: Archiv
Thema: Lesen/Schreiben auf lokalem Memory
Antworten: 6
Zugriffe: 653

Re: Lesen/Schreiben auf lokalem Memory

Lesen: Ja
Lesen UND Schreiben : Nein

Dann brauchst du sowas hier: http://www.cmsoft.com.br/index.php?opti ... Itemid=168
von Lucas-
3. Feb 2012 19:07
Forum: Archiv
Thema: Unterschiedliche Ergebnisse zwischen Pool-Rechnern und Gris
Antworten: 2
Zugriffe: 768

Re: Unterschiedliche Ergebnisse zwischen Pool-Rechnern und G

Das Problem liegt wahrscheinlich daran, dass du z.b. die Variable twoPointOccs[x][y] von allen threads der work-group gleichzeitig erhöhnen lässt ohne entweder die atom-functions oder parallele Algorithmen wie die Reduktion aus Folie 22 zu verwenden. Hier ein guter Link warum das dann zu Fehlern füh...
von Lucas-
31. Jan 2012 16:38
Forum: Archiv
Thema: Performance
Antworten: 24
Zugriffe: 4034

Re: Performance

Ja war ich. Habe den exact gleichen Code nun auf dem teachnode05 getestet und mit loop 100: CPU 10969 millisec OCLGPU 2392 millisec. Was sind das jetzt für Zeiten? 100 Loops können das irgendwie nicht sein, da die reine cpu variante da so 100*1250 ms braucht. Also bei uns läuft der code auf dem clu...
von Lucas-
31. Jan 2012 14:12
Forum: Archiv
Thema: atomic_inc
Antworten: 10
Zugriffe: 1139

Re: atomic_inc

Die Funktion ist so deklariert: int atomic_inc ( volatile __local int *p)
D.h. du musst vor dein Argument ein "&" setzen, damit auf den Speicher des Arguments gezeigt wird
von Lucas-
29. Jan 2012 21:25
Forum: Archiv
Thema: Fehler im python comparer
Antworten: 7
Zugriffe: 776

Re: Fehler im python comparer

Hallo, ich habe in meinem File an einigen Zeilen 0. aber nich an alle. In der Aufgabenstellung hiess es man muss die Matrix mit nullen intialisieren und nur die untere Dreiecksmartrix und die Diagonale berechenen. Deshlab sind bei mir einige nullen Gruesse Die Ausgabedatei stellt aber nur die Werte...
von Lucas-
29. Jan 2012 21:11
Forum: Archiv
Thema: CL_DEVICE_NOT_FOUND und ein anderes Problem
Antworten: 1
Zugriffe: 509

Re: CL_DEVICE_NOT_FOUND und ein anderes Problem

zu 1.: Auf den Clustern kann man opencl nur auf der GPU ausführen, d.h. du musst dort immer mit "-oclgpu" starten

Arrays funktionieren ganz normal, sollten -soweit ich das verstanden habe - allerdings nur __local deklariert werden, da sie sonst in den Grafikspeicher wandern, was ungünstig wäre
von Lucas-
27. Jan 2012 00:56
Forum: Archiv
Thema: Performance
Antworten: 24
Zugriffe: 4034

Performance

Würde mich mal interessieren wie hoch der speed-up zwischen GPU/reiner CPU Variante bei anderen Gruppen auf den cluster-Rechnern ist.

Bei uns liegt er bei ~13, aber ich bin mir sicher, da ist noch einiges möglich :idea:

Zur erweiterten Suche